Roboitalia.com - Il primo portale in Italia sulla robotica amatoriale

Roboitalia.com - Il primo portale in Italia sulla robotica amatoriale (http://forum.roboitalia.com/index.php)
-   Progettazione (http://forum.roboitalia.com/forumdisplay.php?f=18)
-   -   uNav various experiments by landyandy (http://forum.roboitalia.com/showthread.php?t=10957)

landyandy 18-06-2015 23.05.46

uNav various experiments by landyandy
 
....ovvero creare una sorta di repository sui vari esperimenti che in qualche maniera verranno usati con la mia uNav.

Non necessariamente gli argomenti avranno un filone logico, ma sicuramente tutti gli argomenti avranno la uNav come oggetto a cui ricondursi.

Potranno essere semplici idee che probabilmente non vedranno mai la luce oppure il più delle volte esperimenti da me eseguiti.

Non mancheranno anche possibili richieste di aiuto.


La prima cosa che voglio postare è proprio il sistema di propulsione che ho intenzione di utilizzare nelle prime prove con la Nav.

Come capita spesso, quando si ha a che fare con una piattaforma evoluta che non si conosce, è saggio iniziare a prendere fiducia, utilizzando hardware di contorno a basso impatto monetario ma che garantisca comunque un appropriato livello tecnologico tale da garantire un buon livello di studio/esperienza, senza il rischio di distruggere un componente "di qualità" solo a causa di una svista, causata da inesperienza.

In questo caso posso dire senza ombra di smentita che le famose "cineserie", sono una manna dal cielo per tutti coloro che, come me, amano la sperimentazione fatta soprattutto di passione per la rielaborazione.
Un po come un "puzzle", o come ho menzionato in un video tempo fa, come in una sorta di "Lego del 21 secolo", la mia passione è stata sempre quella di prendere oggetti da fonti diverse e cercare di "quantificarle" in un progetto che abbia un minimo di senso.

ma torniamo a noi.....

Il sistema di propulsione che ho scelto per le prove, è un prodotto della DAGU
http://www.dagurobot.com/goods.php?id=165

https://lh3.googleusercontent.com/t8...U=w900-h508-no



è un blocco motore/riduttore di prezzo ragionevole, che monta un motore brush da 4,5V, una demoltiplica da 48:1 e assicura una coppia non male di almeno 800 gr*cm, che risulta ovviamente variabile in base al rapporto potenza applicato.
Assorbimento senza carico circa 200mA.
Assorbimento in stallo a circa 4V, circa 2A.

Il kit monta anche un piccolo encoder ad uscita singola da 5V, che permette anche la lettura della velocità, ma non del senso di rotazione.
Purtroppo ha anche due lati secondo me negativi che sono:

il disco, che ha una risoluzione di appena 10 impulsi per giro ed è calettato addirittura in corrispondenza dell'albero maestro del riduttore, il che ne diminuisce ancora di più la precisione.

http://www.tohobby.com/media/catalog...coder-disk.jpg



Gli ingranaggi, tranne l'albero maestro, sono in plastica e per questo non è consigliabile sollecitarli troppo.

https://lh3.googleusercontent.com/vu...0=w900-h509-no

L'unico VERO problema che ho riscontrato è appunto l'utilizzo di un motore con caratteristiche di tensione troppo basse per essere utilizzato con la Nav.

Mi sono dedicato ad una ricerca di motori compatibili come dimensioni circonferenza ma con una tensione di lavoro di circa 12V.

Sono sicuramente sovra dimensionati e se la ruota è costretta allo stallo, sono sicuro che gli ingranaggi interni si trasformano in segatura in pochissimo tempo, ma il rischio vale la candela......


https://lh3.googleusercontent.com/RK...Q=w900-h509-no




--------------------
------------------
---------------
-------------
-----------
---------
-------
----
---
--
-

landyandy 18-06-2015 23.15.54

Sono più lunghi degli originali di circa 3Cm e questo fa si che il blocco della cassa, non possa più fare uso del supporto originale, ma per fortuna, la stessa DAGU aveva previsto la possibilità di un sistema classico ma che vedremo più tardi.



https://lh3.googleusercontent.com/M8...4=w900-h509-no




Il primo problema da affrontare è la differenza, se pur minima, della dimensione della circonferenza che è maggiore a favore dei nuovi motori, di circa 30/10 mm.

Infatti il supporto originale puo' ospitare motori di diametro di circa 14,90mm.




https://lh3.googleusercontent.com/w9...Q=w900-h508-no


https://lh3.googleusercontent.com/vn...k=w900-h508-no




mentre il nuovo motore ha dimensioni pari a circa 15,20mm





https://lh3.googleusercontent.com/Uo...c=w900-h508-no



--------------------
------------------
---------------
-------------
-----------
---------
-------
----
---
--
-

landyandy 18-06-2015 23.22.46

Cosa fare ...............

Ma OVVIAMENTE la cosa più facile ovvero ridurre la cassa di metallo di quei pochi decimi, tramite una bella mola.

Non ci sono problemi di disallineamento finale dell'asse.



https://lh3.googleusercontent.com/HL...Q=w900-h509-no




Raggiunta la dimensione opportuna, lo si innesta dentro l'alloggiamento, fino "a battuta".




https://lh3.googleusercontent.com/pN...c=w900-h508-no




Dicevo che non vi sono problemi di riallineamento, in quanto DAGU, ha previsto l'implementazione dei due fori di misura standard, gia all'interno del supporto, quindi basta riallinearli "et voilà".......



https://lh3.googleusercontent.com/oN...4=w900-h508-no




https://lh3.googleusercontent.com/Ik...Y=w900-h509-no



--------------------
------------------
---------------
-------------
-----------
---------
-------
----
---
--
-

landyandy 18-06-2015 23.30.32

Un po più difficile è stata la ricerca degli ingranaggi per l'asta del motore da 2mm con lo stesso modulo e numero di denti, ma dopo un po di ricerca sono saltati fuori :-)))




https://lh3.googleusercontent.com/8K...g=w900-h509-no



Anche grazie ai consigli di Antonio, sono riuscito a calettare i nuovi ingranaggi dentro l'albero dei motori cosi da avere finalmente il componente perfettamente funzionante..





https://lh3.googleusercontent.com/oN...s=w900-h509-no




Notare che essi saranno posizionati ad una distanza massima di circa 7mm come da originali.




https://lh3.googleusercontent.com/-g...U=w910-h516-no




adesso bisogna reinserire tutti gli altri ingranaggi e vedere se i moduli, modulano.............

tutto OK alla fine, sembrano combaciare perfettamente.




https://lh3.googleusercontent.com/_v...Q=w900-h509-no




--------------------
------------------
---------------
-------------
-----------
---------
-------
----
---
--
-

landyandy 18-06-2015 23.36.50

Supporto ripristinato con l'aggiunta di un po di grasso, per evitare attriti.

Peccato che le due parti non prevedono l'uso di una guarnizione, infatti purtroppo l'unto più "liquido", tende a passare attraverso la giuntura che unisce le due scocche, lasciando un senso di appiccicoso dopo un po di tempo.


https://lh3.googleusercontent.com/aS...c=w900-h509-no



Il confronto finale tra i due motori




https://lh3.googleusercontent.com/X_...g=w910-h516-no



Allora, per stasera ho finito, ma successivamente andrò ad aggiungere tutte quelle specifiche che man mano andrò a verificare tramite esperienza diretta.






byez

astrobeed 19-06-2015 03.41.14

Citazione:

Orginalmente inviato da landyandy (Messaggio 72221)
.
La prima cosa che voglio postare è proprio il sistema di propulsione che ho intenzione di utilizzare nelle prime prove con la Nav.

Credo che ti sia sfuggito un particolare di primaria importanza, per poter funzionare la µNAV richiede un encoder bicanale ad alta risoluzione, almeno 100 cpr, calettato sull'asse motore.
Con un encoder a bassissima risoluzione montato sulla ruota non ci fai nulla.

landyandy 19-06-2015 16.05.47

Citazione:

Orginalmente inviato da astrobeed (Messaggio 72227)
Credo che ti sia sfuggito un particolare di primaria importanza, per poter funzionare la µNAV richiede un encoder

Ma dove sta scritta sta cosa???

Io non ne sapevo niente !!!!!



Vabbe', scherzi apparte, il tuo intervento e' giusto ma non sai che in realta' scova scova, ho trovato anche questo simpatico encoderino, che se le poste si sbrigano a recapitarmelo, visto che lo aspetto da un mese, dovrebbe sostituire l'originale.

http://www.wayengineer.com/images/AB...ic-encoder.jpg


L'ho scelto proprio perche' compatibile con il montaggio.




Non te l'aspettavi eh ?????

:D:D





byez

Caronte 19-06-2015 16.11.55

Citazione:

Orginalmente inviato da landyandy (Messaggio 72233)

http://www.wayengineer.com/images/AB...ic-encoder.jpg


L'ho scelto proprio perche' compatibile con il montaggio.




Non te l'aspettavi eh ?????







byez

LandyAndy 1 - Astrobeed 0

:D:D


Il Corsaro

astrobeed 19-06-2015 16.13.00

Citazione:

Orginalmente inviato da landyandy (Messaggio 72233)
Ma dove sta scritta sta cosa???
Io non ne sapevo niente !!!!!

E' sempre stato detto che tra i prerequisiti per usare la µNAV c'è l'encoder ad alta risoluzione calettato direttamente sul motore, p.e. come quelli che usa Ciro.

Citazione:

L'ho scelto proprio perche' compatibile con il montaggio.
Si monta sempre sulle ruote, non va bene lo stesso, risparmia i soldi e compra due veri motoriduttori con veri encoder :D

astrobeed 19-06-2015 16.13.43

Citazione:

Orginalmente inviato da Caronte (Messaggio 72234)
LandyAndy 1 - Astrobeed 0

Io 2 - LandyAndy 0 :D


Tutti gli orari sono GMT. Adesso sono le: 10.00.17.

Basato su: vBulletin Versione 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.