Discussione: Sensori infrarosso
Visualizza messaggio singolo
  #1  
Vecchio 21-08-2009, 12.21.41
Boston Boston non è collegato
Nuovo robottaro
 
Data registrazione: 21-08-2009
Residenza: Legnago (VR)
Et: 29
Messaggi: 28
Potenza rep: 0
Boston E' per ora ancora un mistero
Question Sensori infrarosso

Salve a tutti!
Sto cercando di fare un sensore IR per ostacoli e come ricevitore sto usando questo schema: http://www.ivotek.it/
(alla lezione 34 del robot Poor) con il primo tipo di ricevitore in foto e utilizanno una resistenza da 39 kohm non avendone da 38. Sul ricevitore vedo solo questa scritta "3302 81a"; su internet non ho trovato nulla a riguardo ma presumo che funzioni a 33 kHz.

Come trasmettitore utilizzo un led IR collegato ad un 18X sulla base di questo progetto:
http://www.phanderson.com/picaxe/ir_1.html
Ho notato per che la corrente in uscita dal processore negativa anzich positiva quando si usa il PWM.

Ho lanciato i seguenti programmi con i seguenti risultati:
1) main: PWMOut 3, 26, 54
il led non si notava nemmeno con il test della fotocamera digitale e nell'uscita del ricevitore non accadeva nulla, invertendolo invece funzionava.

2) main: high 3
semplicemente accendendo il led; la fotocameraindicava una luce violetta sulla punta del led ma dall'uscita del ricevitore c'erano variazioni nell'ordine dei centesimi di volt.

Facendo ancora prove e mettendo una resistenza da 10kohm nel ricevitore, ho notato che il segnale d'uscita varia pi sensibilmente (ex.: da 3,00V a 2.66V).
Come posso fare ad analizzare cos il segnale dal picaxe 18 X??
Rispondi citando