spacer.png, 0 kB

Torna indietro   Roboitalia.com - Il primo portale in Italia sulla robotica amatoriale > Robotica di base > Elettronica > E. Digitale

Rispondi
 
Strumenti discussione Modalità  visualizzazioe
  #1  
Vecchio 05-06-2007, 11.12.58
aduri aduri non è collegato
Robottaro gold
 
Data registrazione: 24-03-2005
Residenza: Genova
Età : 57
Messaggi: 106
Potenza reputazione: 66
aduri E' per ora ancora un mistero
Send a message via Skype™ to aduri
Predefinito 16f877a perde codice

Mi succede una cosa strana dopo alcuni minuti mi si cancella cio' che ho scritto nel pic.
Collegando l'oscilloscopio vedo che l'oscillazione del clock sparisce.
Premetto che ho collegato l'MCLR con un diodo ed una resistenza da 10K al positivo.
Ho settato WDT off e HS o XT (indifferentemente).
Quarzo da 4MHz e 2 condensatori da 22pf.
Premetto che ho provato solo ora ad usare la serie superiore ai pic16f84a e 628a.
Rispondi citando
  #2  
Vecchio 06-06-2007, 07.34.49
ivotek ivotek non è collegato
Robottaro sostenitore
 
Data registrazione: 30-11-2003
Residenza: Ostia Lido
Età : 44
Messaggi: 736
Potenza reputazione: 85
ivotek E' sulla buona strada
Invia un messaggio via MSN a ivotek Invia un messaggio via Yahoo a ivotek
Predefinito

Mi sa che ti è capitato un pic difettoso.
Prova a scrivere nel pic e quando non funziona pù a rileggerlo, se manca il codice è difettoso.

Se il codice è presente, allora hai problemi hardware.
__________________
http://www.ivotek.it
Rispondi citando
  #3  
Vecchio 06-06-2007, 11.37.25
aduri aduri non è collegato
Robottaro gold
 
Data registrazione: 24-03-2005
Residenza: Genova
Età : 57
Messaggi: 106
Potenza reputazione: 66
aduri E' per ora ancora un mistero
Send a message via Skype™ to aduri
Predefinito

Stasera faccio un po' di prove e vedro'.
Grazie
Rispondi citando
Rispondi


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 ospiti)
 
Strumenti discussione
Modalità  visualizzazioe

Regole di scrittura
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code è Attivato
Le smilies sono Attivato
[IMG] è Attivato
Il codice HTML è Disattivato

Vai al forum

Discussioni simili
Discussione Autore discussione Forum Risposte Ultimo messaggio
pic si perde e non capisco dove sharky P. in C, C++ 15 28-02-2010 18.04.33
hardreset del 16F877A Shelkem E. Digitale 6 12-02-2010 06.54.05
Pic 16f877a streetspirit Elettronica 5 11-09-2009 18.40.28
aiuto pic 16f877a Patrick Elettronica 3 21-11-2008 11.07.39
16f877a e assambler _luca_ P. in Assembler 5 11-01-2005 00.26.33


Tutti gli orari sono GMT. Adesso sono le: 05.49.15.


Basato su: vBulletin Versione 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Realizzazione siti web Cobaltica Foligno
spacer.png, 0 kB