spacer.png, 0 kB

Torna indietro   Roboitalia.com - Il primo portale in Italia sulla robotica amatoriale > Robotica di base > Elettronica

Rispondi
 
Strumenti discussione Modalità  visualizzazioe
  #1  
Vecchio 01-12-2014, 15.24.40
L'avatar di landyandy
landyandy landyandy non è collegato
Robottaro sostenitore
 
Data registrazione: 07-02-2010
Residenza: Abruzzo - Teramo
Età : 43
Messaggi: 2,330
Potenza reputazione: 327
landyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua fama
Predefinito Voltmetro FT218

Ciao lavoratori instancabili.

Come da titolo, ho finalmente trovato il tempo per assemblarmi il voltmetro della Futura Elettronica.

Scrivo perchè ho un problema inerente la trasformazione del voltmetro in amperometro attraverso l'uso di una semplice resistenza in parallelo ai capi dell'ingresso.

Il sistema è anche quello consigliato dalla FE stessa.

Nella seconda pagina del link c'è lo schema:
http://www.futuraelettronica.net/pdf...100-FT218K.pdf

Sapendo che il fondo scala dello strumento è di 200mV (1999 ovvero 3 cifre e mezza), debbo creare due portate con fondo scala di 2A e 20A.

tramite ohm scelgo la R equivalente per la portata per i 2 A:

0,200V / 2,00A = 0,1R

mentre per i 20A:

0,200V / 20,00A = 0,01R

L'articolo consiglia, per semplicità, di mettere in parallelo dei valori commerciali standard, ma io ho preferito utilizzare delle resistenze di precisione di valore esatto.




Problema:

Fra un pò posto lo schema ma non capisco come mai quando imposto la portata fino a 2A la misura è OK, (confrontata con un tester commerciale), ma quando switcho a 20A l'indicatore sul display dell'FT, mi rimane sempre a 1.
Il test è avvenuto per mezzo di una lampadina da 12V 1,5A per la portata a 2A, mentre ho usato, due lampadine in parallelo da 12V per avere almeno circa 2,5A, e con il tester classico, per il confronto.

Provo ad abbassare la tensione dell'alimentatore fino a quasi 0V ma sempre 1 mi rimane sul display dell'FT quando imposto a scala 20A.

Le resistenze mi sembrano OK anche se una misura del genere non è alla portata di semplice tester commerciale, l'ho impostato sulla continuità e mi suona per entrambi.
Segno che almeno il contatto esiste.

Dove ho sbagliato?

saluti
landyandy
__________________
------------------------------------------------




-----------------------------------------------

Ultima modifica di landyandy : 01-12-2014 alle ore 22.43.40 Motivo: Aggiunto schema
Rispondi citando
  #2  
Vecchio 01-12-2014, 15.50.17
L'avatar di marnic
marnic marnic non è collegato
Administrator
 
Data registrazione: 24-05-2002
Residenza: Monselice (PD)
Età : 56
Messaggi: 5,458
Potenza reputazione: 418
marnic La sua reputazione è oltre la sua famamarnic La sua reputazione è oltre la sua famamarnic La sua reputazione è oltre la sua famamarnic La sua reputazione è oltre la sua famamarnic La sua reputazione è oltre la sua famamarnic La sua reputazione è oltre la sua famamarnic La sua reputazione è oltre la sua famamarnic La sua reputazione è oltre la sua famamarnic La sua reputazione è oltre la sua fama
Predefinito

Anche nel pdf dicono che forse per i 20A è meglio modificare il valore di R2...
l'indicazione 1 nel display ha qualche significato? in alcuni simboleggia il fuoriscala.

Lavorare con resistenze da 1 centesimo non è cosa da ridere, vedo che hai anche un commutatore, temo che solo lui abbia una resistenza di contatto superiore. Inoltre tu misuri la tensione che cade tra il puntale + e il puntale -
Come ti colleghi al circuito? se lo tieni con le mani ti mando al rogo insieme a Caronte
In sostanza rispetto a 0,01ohm ogni altra resistenza è significativa e potrebbe incidere
__________________
Marnic
Roboitalia Staff
www.fabbrimarco.com
Rispondi citando
  #3  
Vecchio 01-12-2014, 22.20.02
L'avatar di landyandy
landyandy landyandy non è collegato
Robottaro sostenitore
 
Data registrazione: 07-02-2010
Residenza: Abruzzo - Teramo
Età : 43
Messaggi: 2,330
Potenza reputazione: 327
landyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua famalandyandy La sua reputazione è oltre la sua fama
Predefinito

Urka peppa, quindi il problema si riduce alla resistenza complessiva del circuito che sicuramente, unendosi a quella dei cavi (seppur cortissimi) + le due sonde a coccodrillo (non uso le mani per toccare ) + lo switch selettore + varie ed eventuali avrò una R tot di lunga maggiore di 0,01 ohm.

Marnic, sei un uomo di spessore.

Oggi ci sono stato tre ore a ripassare i collegamenti e non ne venivo a capo.

In pratica alla fine mi conviene utilizzare il metodo del parallelo tra una resistenza e un trimmer per la regolazione fine.

Citazione:
l'indicazione 1 nel display ha qualche significato? in alcuni simboleggia il fuori scala.
Si, indica il fondo scala ed adesso la cosa è semplice da capire.

Mi basta che la R si sposti sensibilmente, che ai capi del voltmetro mi trovo una tensione maggiore di 200mV.

Esiste gia un potenziometro di regolazione delle tolleranze dedicato, ma sicuramente essendo i rami sbilanciati, non basta per avere una regolazione omogenea su entrambe le portate.



saluti specificatamente dedicati a Marnic
landyandy
__________________
------------------------------------------------




-----------------------------------------------
Rispondi citando
Rispondi


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 ospiti)
 
Strumenti discussione
Modalità  visualizzazioe

Regole di scrittura
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code è Attivato
Le smilies sono Attivato
[IMG] è Attivato
Il codice HTML è Disattivato

Vai al forum

Discussioni simili
Discussione Autore discussione Forum Risposte Ultimo messaggio
Voltmetro Pic16f876 ialex80 P. in Basic per micro 7 02-06-2010 17.24.26


Tutti gli orari sono GMT. Adesso sono le: 13.58.38.


Basato su: vBulletin Versione 3.8.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Realizzazione siti web Cobaltica Foligno
spacer.png, 0 kB